apache2 mod_python version mismatch

I was getting some warnings in one machine’s Apache 2 web server error log regarding mod_python, see below: [Wed Jan 25 01:29:11.717727 2017] [:error] [pid 4389] python_init: Python version mismatch, expected ‘2.7.5+’, found ‘2.7.9’. [Wed Jan 25 01:29:11.717856 2017] [:error] [pid 4389] python_init: Python executable found ‘/usr/bin/python’. [Wed Jan 25 01:29:11.717864 2017] [:error] [pid 4389] … Read moreapache2 mod_python version mismatch

apache 2 on debian wheezy upgrade failure

After running apt-get update && apt-get upgrade on a Debian Wheezy server package apache2-mpm-prefork:amd64 was removed and package apache2-mpm-itk:amd64 installed instead. ¬†After this change in Apache worker, all Virtualhosts sites on the server stopped working, with the following error format in the logs: [Mon Nov 21 09:57:41 2016] [emerg] [client xxx.xxx.xxx.xxx] (13)Permission denied: mod_fcgid: can’t … Read moreapache 2 on debian wheezy upgrade failure